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INSTITUTIONAL VISION AND MISSION  

 

Vision: 

Development of academically excellent, culturally vibrant, socially responsible and globally 

competent human resources. 

 

Mission: 

➢ To keep pace with advancements in knowledge and make the students competitive 

and capable at the global level. 

➢ To create an environment for the students to acquire the right physical, intellectual, 

emotional and moral foundations and shine as torch bearers of tomorrow's society. 

➢ To strive to attain ever-higher benchmarks of educational excellence. 

 

DEPARTMENT VISION AND MISSION 

Vision: 

To develop globally competent civil engineers who excel in academics, research and are 

ethically responsible for the development of the society. 

Mission of the Department 

➢ To provide quality education through faculty and state of art infrastructure. 

➢ To identify the current problems in society pertaining to Civil Engineering disciplines 

and to address them effectively and efficiently. 

➢ To inculcate the habit of research and entrepreneurship in our graduates to address 

current infrastructure needs of society. 

Program Educational Objectives (PEOs) 

PEO 1 - Engaged in professional practices, such as construction, environmental, 

geotechnical, structural, transportation, water resource engineering by using technical, 

communication and management skills. 

PEO 2 - Engaged in higher studies and research activities in various civil engineering fields 



 

and life time commitment to learn ever changing technologies to satisfy increasing demand 

of sustainable infrastructural facilities. 

PEO 3 - Serve in a leadership position in any professional or community organization or 

local or state engineering board 

PEO 4 - Registered as professional engineer or developed a strong ability leading to 

professional licensure being an entrepreneur. 

 

Program Specific Outcomes (PSOs) 

PSO 1 – Provide necessary solutions to build infrastructure for all situations through 

competitive plans, maps and designs with the aid of a thorough Engineering Survey and 

Quantity Estimation. 

PSO 2 – Assess the impact of anthropogenic activities leading to environmental imbalance 

on land, in water & in air and provide necessary viable solutions revamping water resources 

and transportation for a sustainable development 

 

Program Outcomes (POs) 

 

Engineering Graduates will be able to: 

 

PO1: Engineering knowledge: Apply the knowledge of mathematics, science, engineering 

fundamentals, and an engineering specialization to the solution of complex engineering 

problems. 

 

PO2: Problem analysis: Identify, formulate, review research literature, and analyze complex 

engineering problems reaching substantiated conclusions using first principles of 

mathematics, natural sciences, and engineering sciences. 

 

PO3: Design/development of solutions: Design solutions for complex engineering problems 

and design system components or processes that meet the specified needs with appropriate 

consideration for the public health and safety, and the cultural, societal, and environmental 

considerations. 

 

PO4: Conduct investigations of complex problems: Use research-based knowledge and 

research methods including design of experiments, analysis and interpretation of data, and 



 

synthesis of the information to provide valid conclusions. 

 

PO5: Modern tool usage: Create, select, and apply appropriate techniques, resources, and 

modern engineering and IT tools including prediction and modeling to complex engineering 

activities with an understanding of the limitations. 

 

PO6: The engineer and society: Apply reasoning informed by the contextual knowledge to 

assess societal, health, safety, legal and cultural issues and the consequent responsibilities 

relevant to the professional engineering practice. 

 

PO7: Environment and sustainability: Understand the impact of the professional 

engineering solutions in societal and environmental contexts, and demonstrate the knowledge 

of, and need for sustainable development. 

 

PO8: Ethics: Apply ethical principles and commit to professional ethics and responsibilities 

and norms of the engineering practice. 

 

PO9: Individual and team work: Function effectively as an individual, and as a member or 

leader in diverse teams, and in multidisciplinary settings. 

 

PO10: Communication: Communicate effectively on complex engineering activities with 

the engineering community and with society at large, such as, being able to comprehend and 

write effective reports and design documentation, make effective presentations, and give and 

receive clear instructions. 

 

PO11: Project management and finance: Demonstrate knowledge and understanding of the 

engineering and management principles and apply these to one’s own work, as a member and 

leader in a team, to manage projects and in multidisciplinary environments. 

 

PO12: Life-long learning: Recognize the need for, and have the preparation and ability to 

engage in independent and life-long learning in the broadest context of technological change. 

 

 



 

SOFTWARE APPLICATION LABORATORY 

VTU SYLLABUS 

Subject Code : BCVL606                                           I.A. Marks : 50 

Hours/Week : 03                                       Exam Hours : 03 

Total Hours : 40                                       Exam Marks : 100 

 

Use of civil engineering software 

1. 3D analysis of multistoried frame structures 

2. Analysis of plane trusses, continuous beams, portal frames 

Project Management-Construction scheduling using any Project management software 

a) Understanding basic features of Project management software 

b) Constructing Project: create WBS, Activities, and tasks and Computation Time using 

Excel spread sheet and transferring the same to Project management software 

c) Identification of Predecessor and Successor activities with constrain 

d) Constructing Network diagram and analyzing for Critical path, Critical activities and other 

non-critical paths, Project duration, Floats. 

e) Study on various View options available 

f) Basic understanding about Resource Creation and allocation 

g) Understanding about Splitting the activity, linking multiple activity, assigning Constrains, 

Merging Multiple projects, Creating Baseline Project 

One Project having min 20 activities needs to be designed and analyzed Project management 

software as a guideline Project could be from Buildings: Residential / School / college / 

Hospitals / Technology park, Industrial, Typical Road Construction project, Sewage / water 

Treatment Project, Bridge / elevated structure project, Water supply system 9hrs 

GIS applications using open-source software 

a. To create shape files for point, line and polygon features with a map as reference. 

b. To create decision maps for specific purpose 

Use of EXCEL spread sheets 

Computation of earthwork, Design of horizontal curve by offset method, Design of super 

elevation 

 

 

 

 

 

 



 

SOFTWARE APPLICATION LAB (BCVL606) 

 
 Course Outcomes 

After studying this course, students will be able to: 
RBT 

CO1: 
Analyze the continuous beams, frames, trusses and multi-storey 

buildings using Civil Engineering Software 
L4 

CO2: 
Create points, lines and polygons to determine latitude & longitude, 

length and area using GIS application 
L6 

CO3: 
Create task, scheduling, creating base line, critical path for an activity 

using Microsoft Project application 
L6 

CO4: 
Formulate a spread sheet for Horizontal curve, Super elevation, and 

earthwork using Excel application 

L6 

 

The Correlation of Course Outcomes (CO’s) with Program Outcomes (PO’s) and 

Program Specific Outcomes (PSO’s) 

 

Subject 

Code: 
18CVL66 TITLE: Software Application Laboratory Faculty Name:  

List of 

Course 

Outcomes 

Program Outcomes 

PO1 PO2 PO3 PO4 PO5 PO6 PO7 PO8 PO9 PO10 PO11 PO12 PSO1 PSO2 

CO-1 2 2 - - 3 - - - - 2 - 2 2 - 

CO-2 2 - - - 3 - - - - 2 - 2 2 - 

CO-3 2 2 - - 3 - - - - 2 2 2 2 - 

CO-4 2 2 - - 3 - - - - 2 - 2 2 - 

 

 

 

 

 

 

 

 

 



 

SOFTWARE APPLICATION LAB (BCVL606) 

 
Sl. 

No 
Experiment Name Page No 

 Introduction to E-tabs 2 

1 3D analysis of multistoried frame structures 7 

2 Analysis of continuous beams, portal frames & plane trusses 21 

 Introduction to MS project 29 

3 Project Management-Construction scheduling 30 

 Introduction to QGIS software 45 

4 To create shape files for point, line and polygon features with a map as 

reference. 
46 

 Use of EXCEL spread sheets: 

 

5 

Computation of earthwork 52 

Design of horizontal curve by offset method 

 

53 

Design of super elevation 54 
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Contents 

1.1 Introduction to ETABS 

1.2 Objectives 

1.3 3D analysis of multi-storey buildings 

1.4 Analysis of Continuous beams 

1.5 Analysis of portal frames 

1.6 Analysis of trusses 
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Introduction to Multi-Storey Analysis of Frame Structure 

 

Analysis of the structure mainly deals with determination of internal forces like axial 

compression, bending moment, shear force, twisting moments etc. in component members, for 

which these members are designed under the action of given external loads. 

The frames can be analyzed either manually or by using softwares. The most commonly 

used method for analyzing the frames manually is Kani’s method. 

Some of the commonly used softwares to analyze frames are: 

1. STAAD.Pro 

2. NISA civil 

3. SAP 

4. STRAAP 

5. ETABS 

6. SAFE 

7. ANSIS, etc... 

In the present manual ETABS are used for the analysis of frames. 

1.1 Introduction to Extended Three-dimensional Analysis of Building Systems (ETABS) 

ETABS is a structural and earthquake engineering software produced for the analysis and design 

of a wide variety of structures. ETABS is designed for engineers by engineers who understand 

the process of modeling, analysis and designing a structure. Developed in context with the grid-

like geometry unique to multi-story building design, ETABS tailors control features and software 

functions to this class of structure. The graphical interface, object-based modeling 

tools, nonlinear and dynamic computational processes, and output options all coordinate to 

streamline and simplify building design. 

The basic three activities, which are to be carried out to achieve the goals, are: 

• Modeling of Structural Systems 

• Loading, Analysis, and Design 

• Output, Interoperability, and Versatility 

https://wiki.csiberkeley.com/display/kb/Nonlinear
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a) Modeling of Structural Systems 

The observation that multi-story buildings typically consist of identical or similar floor plans, 

repeating in the horizontal, and supported by gravity and lateral systems in the vertical, is 

fundamental to ETABS application. ETABS enables the methods and technologies at the 

forefront of structural engineering, providing a suite of modeling features: 

• Templates for global-system and local-element modeling 

• Custom section geometry and constitutive behavior 

• Grouping of frame and shell elements 

• Link element assignment for characterization of isolators, dampers, and other advanced 

seismic systems 

• Hinge property specification 

• Automatic meshing with optional user control 

• Extrusion tools for radial geometry 

• Diaphragm constraints 

• Editing and assignment features for plan, elevation, and 3D views 

b) Loading, Analysis, and Design 

Once modeling is complete, ETABS automatically generates and assigns code-based loading 

conditions for gravity, seismic, wind, and thermal forces. Users may specify an unlimited 

number of load cases and combinations. 

Analysis capabilities then offer advanced nonlinear methods for characterization of static-

pushover and dynamic response. Dynamic considerations may include modal, response-spectrum 

or time-history analysis. P-delta effect account for geometrical nonlinearity. 

Given enveloping specification, design features will automatically size elements and systems, 

design reinforcing schemes, and otherwise optimize the structure according to desired 

performance measures 

 

  

https://wiki.csiberkeley.com/display/kb/Material+nonlinearity
https://wiki.csiberkeley.com/display/kb/Frame
https://wiki.csiberkeley.com/display/kb/Shell
https://wiki.csiberkeley.com/display/kb/Link
https://wiki.csiberkeley.com/display/kb/Hinge
https://wiki.csiberkeley.com/display/kb/Discretization
https://wiki.csiberkeley.com/display/kb/Load+case
https://wiki.csiberkeley.com/display/kb/Load+combination
https://wiki.csiberkeley.com/display/kb/Modal+analysis
https://wiki.csiberkeley.com/display/kb/Response-spectrum+analysis
https://wiki.csiberkeley.com/display/kb/Time-history+analysis
https://wiki.csiberkeley.com/display/kb/P-Delta+effect
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c) Output, Interoperability, and Versatility 

Output and display formats are also practical and intuitive. Moment, shear, and axial force 

diagrams, presented in 2D and 3D views with corresponding data sets, may be organized into 

customizable reports. Also available are detailed section cuts depicting various local response 

measures. Global perspectives depicting static displaced configurations or video animations of 

time-history response are available as well. 

 ETABS also features interoperability with related software products, providing for the 

import of architectural models from various technical drawing software, or export to various 

platforms and file formats. SAFE, the floor and foundation slab design software with post-

tensioning (PT) capability, is one such option for export. CSI coordinated SAFE to be used in 

conjunction with ETABS such that engineers could more thoroughly detail, analyze, and design 

the individual levels of an ETABS model. While ETABS features a variety of sophisticated 

capabilities, the software is equally useful for designing basic systems. ETABS is the practical 

choice for all grid-like applications ranging from simple 2D frames to the most complex high 

rises. ETABS is sophisticated, yet easy to use, special purpose analysis and design program 

developed specifically for building systems.  

              ETABS version 9 features an intuitive and powerful graphical interface coupled with 

unmatched modeling, analytical and design procedures, all integrated using a common database. 

Although quick and easy for simple structure, ETABS can also handle largest and complex 

building models including a wide range of nonlinear behaviors, making it the tool of choice for 

structural engineers in the building industry 

1.2 Objective 

To analyze multistory buildings, continuous beams, frames and trusses using ETABS software 

What ETABS can do!` 

ETABS offers the widest assortment of analysis and design tools available for the structural 

engineer working on building structures. The following lists represent just a portion of the types 

of system and analyses that ETABS can handle easily. 

• Multi-story commercial, government and health care facilities 

• Parking garages with circular and linear ramps 

https://wiki.csiberkeley.com/display/safe/Home
https://wiki.csiberkeley.com/display/kb/Tendon
https://wiki.csiberkeley.com/display/kb/Tendon
http://www.csiberkeley.com/
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• Staggered truss buildings 

• Buildings with steel, concrete, composite or joist floor framing 

• Complex shear wall with arbitrary openings 

• Building subjected to any number of lateral and vertical cases and combinations, 

including automated wind and seismic loads 

• P delta analysis with static or dynamic analysis 

• Construction sequence loading analysis 

• Multiple linear and nonlinear time history load cases in any directions 

• Nonlinear static pushover 

• Building with base isolation and dampers 

Features in ETABS software 

1. Analysis option: 

ETABS has many analysis options which includes 

• P-Delta Analysis 

• Dynamic Analysis 

• Eigen Vector Analysis 

• Ritz Vector Analysis 

• Linear Analysis 

• Non-linear Analysis 

• Static Non-Linear Analysis 

• Construction Sequence Analysis 

2. Locking and Unlocking the model: 

From main menu → Option → lock model/unlock model 

Check model: 

 Before running the analysis, use check model to ensure that the objects do not overlap and that 

are connected with each other. 

From main menu → Analysis → check model 
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3. Editing the model: 

Edit → Edit Grid data 

→ Edit Storey data 

→ Edit Reference line 

→ Add model from template (2D frame or 3D frame) 

→ Merge areas 

→ Joint lines / Joining selected beams or selected columns 

4. Text/ Graphical output: 

To view loads: 

From main menu → Display → Show loads → Frame/lines 

To view design info: 

From main menu → Design → Concrete frame design → Display design info 

To view other Tables: 

From main menu → Display → Show tables → Select required boxes 

Exporting the files: 

From main menu → File → Export 

Save the model as etabs.e2k text file (like a Staad editor file) 

You can also export to SAP or SAFE or EXCEL database or dsef 

Importing the file: 

From main menu → File → Import → ETABS.e2k. Text file or STAAD file. 

Options/Preferences: 

From main menu → Option → Preferences → Concrete Frame Design (Select code & other 

parameters) 

→ Shear wall design 

→ Reinforcement/ bar size (add new or modify existing) 

→ Live load reduction 

Auto saving the model:  

From main menu → Option → Auto save model → Set time → ok. 

Loads 

Combination of existing loads 
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→Envelop of combinations 

To draw column or beam to required location: 

There is no ore command here. Set snap grip on and draw column or beam any where we want. 

To draw secondary beam at required distance  

Set plan view to required floor in left window → Right click on the screen (not on the slab) → 

plan fine grid spacing → plan fine grid spacing= 500 say → ok.  

From main menu → Draw → Snap to → Fine grid → From main menu → Draw line objects → 

Draw line objects → Draw line → property = ------ (moment release = pinned and  draw beam at 

required distance)  

To get out from grid line (above option) 

Draw → snap to → fine grid 

1.3 3D Analysis of Multi-storey buildings 

Example 

No of Stories: 3  

No of bays in X-direction: 5 

No of bays in Y-direction: 5 

Spacing in X-direction: 8 

Spacing in Y-direction: 8 

Typical storey height: 3m 

Basement height: 3m 

Concrete grade: M20 

Steel grade: HYSD 415 grade 

Column size: 230X400 

Beam size: 230X250 

Slab thickness: 150mm 
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Step by Step Procedure 

Step1: Creation of Geometry 

Open ETABS program. 

Set the units of the model in the drop down box in the lower right hand corner of ETABS 

window; click the drop down box to set the units in N-mm. 

From main menu → File→ New model → Select No. 

Building pan grid system and storey data definition will be displayed. 

 

 

 

 

 

 

 

 

 

 

 

 

Note: you can change grid spacing by choosing custom grid spacing, for column varying spacing 

then edit grid to change the storey height by choosing custom storey data, then click on edit 

storey data. 

Go to Main menu → Edit Storey data → Edit storey. 
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Step 2: Define material properties 

From main menu → Define → Material property → Add new material → Material name = M20 

→Concrete cubic comp. Strength fck = 20N/mm2 

→Bending Reinforcement yield strength fy = 415N/mm2 

→Shear Reinforcement yield strength fy = 415N/mm2 → Ok → Ok. 

 

 

 

 

 

 

 

Step 3: Define Frame Section 

Define Beam: 
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From main menu → define → Frame section → Add rectangular → Material name = M20 

(select) 

→ Section Name: B230X250 

→Click reinforcement  

→Select Beam → Concrete cover to the rebar center top = 30mm 

In the same manner define other beams  
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Define columns: 

→Add rectangular → section name = C1 

→Material name = M20 

→Dimensions: Depth = 400mm 

    Width = 230mm 

→Click reinforcement  

→Select column 

→Select Rectangular 

→Ties as rectangular 

→Cover to the reinforcement = 40mm 

→Reinforcement to be designed → Ok → Ok 

In the same manner define other columns 

Define slab: 

From main menu → define → wall/slab/deck section → Add new slab → 
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→Section name = Slab150 

→Material name = M20 

→Select membrane 

→Select thin membrane → Ok → Ok. 

 

Step 5: Drawing Beams, Columns & slabs 

Drawing Beams: 

From main menu → Draw → Draw line objects → create lines in region  

→Select required beam size in the drop down list 

→Click or select the beam in the plan view (left window) with similar storey option and select 

all beams to assign the beam property 

Drawing Columns: 

From main menu → Draw → Draw line objects → create columns in region. 

→Select required column size in the drop down list 

→ Click or select the column joints in plan view with similar storey option to assign the column 

property 
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If necessary change the orientation of the column by specifying the angle as 90° 

Note: 

Select  set building objects on top of the tool bar 

Select  line sections under objects view options 

Special effects: 

 Object Fill  

      Extrusion → Ok. 

To view the rendered view 

 Set building view objects on top of the tool bar 

      Line section 

Special effects: 

 Object Fill  

      Extrusion 

      Apply to all windows → Ok  

Step 6: Assigning Support condition 

Set base floor plan view in left window → set column points  

From main menu → Assign → Joint/point → Restraints (support) → Select Fixed → Ok 

To view support assigned 

From top tool bar      Set building view option → visible in view 

   Supports → Ok 

Go to Elevation view and for other views, click  arrow at top of tool bar 
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Step 7: Defining loads 

1. Gravity loads (dead load & live load cases)  

From main menu → Define→ Static Load cases →  

Load = SDL (Super imposed dead load) 

Type = Dead 

Self weight multiplier = 0 → Add New load → Ok 

Load = Wall  

Type = Dead 

Self weight multiplier = 0 → Add New load → Ok 
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Assigning the loads: 

Activate the left window and set to plan view → Activate or select similar storey option (at 

bottom) and select all slabs. 

From main menu → Assign→ Shell/Area loads → Uniform → load case name = SDL 

Load = 1.5 kN/m2 

Direction gravity → Ok 

In the same manner, assign load case name = live uniform load  

Load = 2.0 kN/m2 

Direction gravity → Ok 

Assigning wall loads: 

9” wall load = 12 kN/m (for external or outer beams) 

41/2” wall load = 6 kN/m (for internal beams) 

In the left side of window select all outer beams in top floor by setting similar storey option and 

view the status bar to know no. of beams selected  

→ From main menu → Assign→ Frame/ line loads → Distributed load case name = wall unit in 

kN-m 
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→ Forces 

→ Direction gravity 

Uniform load = 12 kN/m 

Replacing existing load → Ok 

In the same manner, apply 41/2” wall udl load to internal beam by setting all floor options 

To see the load assigned: 

Right click on particular member, corresponding load → Ok 

Note: For point load 

From main menu → Assign→ Joint/point loads → load case name = Dead unit in kN 

Replace existing load 

For global = 10kN → Ok 
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Step 8: Design 

Selecting Indian code 

From main menu → options→ preferences → concrete frame → design code = Indian 

IS456:2000 for RCC → Ok 

Defining load combinations 

From main menu → define → load combinations → Add new load combo 
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Load combination name = DL + LL 

Load combination type → Add → change scale factor = 1.5 for DL & LL by clicking add button 

→ Ok → Ok 

Selecting Design load  

From main menu → Design→ Concrete Frame Design→ Select design combo → select one 

combination load from the list → Add → Ok 

Step 9: Analysis 

From main menu → Analysis → Run analysis  

After completing process, the model automatically displaces deformed shape view and the model 

is locked (you cannot do any changes to the model) 

Step 10: Running the Design process 

From main menu → Design→ Concrete Frame Design→ Select design/ check of structure → 

design results will be displayed on the model 

Graphical output 

Activate 3D view in right window by clicking title bar → Set elevation view =1 → From main 

menu → Display → Show member force/stress diagram → frame/pier/ spandul forces 

→ Select any load case say DL + LL 

Select moment → 3 option 

Uncheck the fill diagram 

If it is checked, we have to deselect → check the showed values on the diagram check box → Ok 

Right click on any beam in right window which will display diagrams for the beams 

Select scroll for values (right top window which will show at different distance along the beam) 

To check the display:  

Activate right window → from main menu → Display → Show un-deformed → click on 3D 

button from top tool bar to display 3D view 

To view reinforcement details: 

Running the design process 

From main menu → Design → Concrete frame design → Start design/check of structure → 

design results will be displayed in the model. 
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Set to elevation view in the right window → reinforcement area will be displayed on the frame. 

Right click on any beam or column.  

→ Summary 

→ Flexural details 

→ Shear details  

→ Envelop → Ok 

View the % of Steel on beams and column 

From main menu → Design → Concrete frame design → Display design information → select 

design output → rebar % → Ok 
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Future Study: https://www.youtube.com/watch?v=LOtuwW9-G68 
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1.4 Analysis of Continuous Beam 

 

Problem 1 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
Software Application Lab                                                                 BCVL606 
 

Department of Civil Engineering, ATMECE Page 22 
 

Problem 2 
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Problem 3 

 

 

 

Future Study: https://www.youtube.com/watch?v=ZV9DN8tIVkw 
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1.5 Analysis of Frames 

 

Problem 1 
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Problem 2 
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Problem 3 
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1.6 Analysis of Truss 
 

Analyze the TRUSS as shown in Figure  

 

 

 

Future Study: https://www.youtube.com/watch?v=5ThM2IPDmUA 
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Contents:  

2.1 Microsoft Project 

2.1.1 Introduction to MSP 

2.1.2 Objectives 

2.1.3 Creating a schedule 

2.1.4 Setup resources 

2.2 QGIS 

2.2.1 Introduction to QGIS 

2.2.2 Objectives 

2.2.3 Initializing QGIS 

2.2.4 Creating Shape files 

2.2.5 Future Study 
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2.1 MICROSOFT PROJECT (MSP) 
 

2.1.1 Introduction to Microsoft Project 
 

MS Project, the project management software program by Microsoft is a very handy tool for 

project managers that help them develop a schedule, assign resources to tasks, track the 

progress, manage the budget, and analyze workloads for ongoing projects.  

2.1.2 Objective: 

To schedule, assign resources, tracking progress, managing budget of ongoing projects using 

MSP software 

MSP INTIAL SETTINGS 

STEP – 1:  

Open MSP > File > Display> 

Choose INR as currency for Indian Projects 
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STEP – 2  

File > Schedule  

Change work hours if required to suit the project or conditions 

 

2.1.3 CREATING A NEW SCHEDULE  

Step 1: Start Date  

Click Project tab -> Properties Group -> Project Information.  

A dialog box appears. In the start date box, type 18/01/18, or click the down arrow to display 

the calendar, select January 18, 2018 (or any date of your choice).  

Click OK to accept the start date. 
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Step 2: Set Up Calendar  

Click Project tab -> Properties Group -> Project Information.  

Click the arrow on the Current Date dropdown box. A list appears containing three base 

calendars.  

24 Hour: A calendar with no non-working time.  

Night Shift: Covers 11 PM to 8 AM, night shifts covering all nights from Monday to Friday, 

with one hour breaks.  

Standard: Regular working hours, Monday to Friday between 8 AM to 5 PM, with one hour 

breaks.  

Step 3: Adding Exceptions to Calendar  

Exceptions are used to modify a Project calendar to have a non-standard workday or a non-

working day. You can also allot unique working hours for a particular resource as well.  

Here is an example to create a non-working day, which could be because of a holiday or office 

celebrations or events other than the standard office work effort. 

Click Project tab -> Properties Group -> Change Working Time. 
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Step 4: Setting up Resource Calendar  

Just like you can change a Standard Base Calendar, you can change the work and non-working 

time for each resource. You can modify the resource calendar to accommodate flex-time, 

vacation time, training time, etc.  

Also remember, Resource Calendar can only be applied to work resources and not to material 

and cost resources.  

By default when we create the resources in a plan, the resource calendar matches the Standard 

base calendar. And any changes you make to the Project Calendar, gets reflected automatically 

in resource calendars, except when you create an exception in the resource calendar. In that case 

even if you update the project calendar, the exception in resource calendar is not affected. 

Click Project tab>Properties group>Click Change Working Time  

Change Working Time dialog box appears.  

Click the down arrow for the “For Calendar” drop-down box. 

Step 5: Create Non-working Days 
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Click Project tab -> Properties group -> Click Change Working Time.  

The Change Working Time dialog box appears.  

Click the down arrow for the “For Calendar” dropdown box.  

Select the resource for whom you want to change work schedule.  

Click “Work Weeks” tab.  

Double-click the [default] cell below the Name column heading.  

Under “Selected Day(s)” choose any day you want to change the work schedule. 

Click any day (we have chosen Friday) and use the radio button “Set days to nonworking time”.  

Click OK to close the Dialog box. You will now see all Fridays are greyed out in the calendar. 

BUILD A SCHEDULE  

Enter Task 

In Gantt Chart View, just click a cell directly below the Task Name column. Enter the task 

name. 
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Enter Duration 

A duration of the task is the estimated amount of time it will take to complete a task. As a 

project manager you can estimate a task duration using expert judgment, historical information, 

analogous estimates or parametric estimates.  

You can enter task duration in terms of different dimensional units of time, namely minutes, 

hours, days, weeks, and months. You can use abbreviations for simplicity and ease as shown in 

the following table. 

Value you want to enter  Abbreviation  Appearance  

45 minutes  45 m  45 mins  

2 hours  2h  2 hrs  

3 days  3d  3 days  

6 weeks  6w  6 weeks  

2 months  2mo  2 mons  

 
In Gantt Chart View, click the cell below Duration column heading. Enter the duration.  

You can also enter Start and Finish date and MS Project will calculate the duration on its own. 

(Task 6 in the following screen shot) 

You can enter text as well when you don’t have a duration metric currently. (Task 3 in the 

following screenshot) 
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Elapsed Duration (Dummy Activities)  

You can enter elapsed duration by preceding any duration abbreviation with an “e”. So 1ew is 
seven 24-hour days.  
For example, when you are ‘Waiting for the paint to dry’. And it takes 4 days for this to happen. 

It does not need a resource or a work effort, and all you are doing is waiting for it to dry. You 

can use 4ed as the time duration, which signifies 4 elapsed days, the paint can dry regardless of 

whether it is a weekend or if it falls on a holiday. Here in this example, the drying occurs over 

24 hours over the weekend 

 

Create Milestones 

In Project Management, Milestones are specific points in a project timeline. They are used as 

major progress points to manage project success and stakeholder expectations. They are 

primarily used for review, inputs and budgets.  

Mathematically, a milestone is a task of zero duration. And they can be put where there is a 

logical conclusion of a phase of work, or at deadlines imposed by the project plan.  

There are two ways you can insert a milestone. 

Method 1: Inserting a Milestone  
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Click name of the Task which you want to insert a Milestone 

Click Task tab -> Insert group -> Click Milestone. 

Click on <New Milestone> to change its name. 

 

Method 2: Converting a Task to a Milestone 

Click on any particular task or type in a new task under the Task Name Heading.  

Under Duration heading type in “0 days “. 

Create Summary Task 

There can be a huge number of tasks in a project schedule, it is therefore a good idea to have a 

bunch of related tasks rolled up into a Summary Task to help you organize the plan in a better 

way. It helps you organize your plan into phases.  

In MS Project 2013, you can have several number of sub-tasks under any higher level task. 

These higher level tasks are called Summary Task. At an even higher level, they are called 

Phases. The highest level of a plan’s outline structure is called the Project Summary Task, 

which encompasses the entire project schedule. 
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Method 1  

Select the names of Task 4 and Task 5. 

Click Task Tab  group Insert Click Summary 

Method 2 

Select “Insert Task”. A <New Task> is created. 

Now select Task 4 and Task 5.  

Click Task tab  Schedule group Click Indent Task 

 

Link Tasks 

Once you have a list of tasks ready to accomplish your project objectives, you need to link them 

with their task relationships called dependencies. 

In MS Project, the first task is called a predecessor because it precedes tasks that depend on it. 

The following task is called the successor because it succeeds, or follows tasks on which it is 

dependent. Any task can be a predecessor for one or more successor tasks. Likewise, any task 

can be a successor to one or more predecessor tasks.  

There are only four types of task dependencies, here we present them with examples.  
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• Finish to Start (FS): Finish the first floor before starting to build the second floor. 

Most used.  

• Finish to Finish (FF): Cooking all dishes for dinner to finish on time.  

• Start To Start (SS): When doing a survey, we would seek survey responses but 

will also start tabulating the responses. One does not have to finish collecting 

survey response before starting the tabulation.  

• Start to Finish (SF): Exam preparation will end when exam begins. Least used.  

Method 1  

Select the two tasks you want to link. In the following screenshot taken as an example, we have 

selected names, Task 1 and Task 2. 

Click Task tab -> Schedule group -> Link the Selected Tasks. 

Method 2 

Double click a successor task you would like to link. 

Click Predecessors tab  

In the Table, click the empty cell below Task Name column. 

Choose the predecessor task. Click OK. 
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Respect Links 

If you are in Manually Scheduled mode, any change in duration of the predecessor task will not 

reflect on Start date of Task 4. For example, Task 4 starts on 11/01/2018 which is the next day of 

Finish date of Task 3. 

 
Now when we change the Duration of Task 3 from 4 to 7 days, the start date is not 

automatically updated for Task 4 in Manual Scheduling. 
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You can force MS Project to respect the link (dependency) by doing the following:  

• Select Task 4.  

• Click Task tab -> Schedule group -> Respect Links.  

Switching Task – Manual to Automatic 

MS Project by default sets new tasks to be manually scheduled. Scheduling is controlled in two 

ways.  

Manual Scheduling: This is done to quickly capture some details without actually scheduling 

the tasks. You can leave out details for some of the tasks with respect to duration, start and 

finish dates, if you don’t know them yet.  

Automatic Scheduling: This uses the Scheduling engine in MS Project. It calculates values such 

as task durations, start dates, and finish dates automatically. It takes into accounts all 

constraints, links and calendars. 

Method 1  

If you want to change the mode for a particular task, say Task 5 in the following example. Click 

on Task Mode cell in the same row. Then, click the down arrow to open a dropdown box, you 

can select Auto Scheduled. 

Method 2  

Click Task -> Tasks group -> Auto Schedule. 

Method 3  

To switch completely to Auto Schedule mode:  

Toggle the scheduling mode of the plan by clicking the New Tasks status bar (at the bottom-left) 

and then selecting Auto scheduling mode. 

Go to File tab and click Options. Then click Schedule tab and under scheduling options for this 

project select “All New Projects” from the dropdown box. Under new tasks created, select 

“Auto Scheduled” from the dropdown box. 

 

2.1.4 SETUP RESOURCES  

In project management terminology, resources are required to carry out the project tasks. They 

can be people, equipment, facilities, funding, or anything (except labor) required for the 
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completion of a project task. Optimum Resource Scheduling is the key to successful project 

management. 

Resource Types 

• Work resources: People and equipment to complete the tasks.  

• Cost resources: Financial cost associated with a task. Travel expenses, food 

expenses, etc.  

• Material resources: Consumables used as project proceeds. For example, paint 

being used while painting a wall.  

Click View tab -> Resource Views group -> Click Resource Sheet.  

Click the cell directly below the Resource Name heading column.  

Enter Resources as an individual person, job function or group. 

 

Entering a value less than 100% in Max.Units would mean you expect the resource capacity to 

be lower than a full-time resource. So 50% would mean the individual works for half of the 

normal full capacity, so if a normal work week is 40 hours, this equals 20 hour capacity. 

Cost of Task = Work Value (in number of hours) x Resource’s Pay Rate. 
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ASSIGN RESOURCES TO TASK  

Method 1 

• Click View Tab -> Gantt Chart View -> Resource Name column.  

• Click the box below the Resource Name column for the task you need the 

resource to be assigned.  

• From the dropdown, choose the resource name. 

 

PLAN DURATION, COST & TIME  

Check Plan’s Duration 

In Gantt Chart View -> View Tab -> Split View group -> Timeline checkbox. 



 
Software Application Lab                                                                 BCVL606 
 

Department of Civil Engineering, ATMECE Page 43 
 

 

Check Plan’s Cost 

Click View tab -> Data group -> Tables -> Cost. 

 

Check Plan’s Work 

Click Report Tab >View Reports group >click Resources >click Resource overview 
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View Critical Path 

Critical Path is the succession of connected tasks that will take the longest to complete. The 

word “critical” does not mean that the tasks are complex or important or need to be closely 

monitored, but the focus is on terms schedule that will affect the project finish date.  

So, if you want to shorten the duration of a project, you should first start with activities/tasks 

on the critical path. Critical path can be a single sequence of tasks (a singlecritical path) or there 

can be more than 1 critical paths for a single project. While schedule changes are made, it is also 

likely that the critical path will change from time to time.  

One needs to always focus on the Critical Path first, when one wants to apply fast-tracking or 

crashing to shorten the project duration.  

Slack or Float are key to understanding Critical path. There are two types of Float:  

• Free Float: It is the amount of time a task can be delayed without delaying 

another task.  

• Total Float: It is the amount of time a task can be delayed without delaying the 

completion of the project.  

In Gantt Chart view -> Format Tab -> Bar Styles Group -> Check the Critical Tasks box ON. 

All task bars in the critical path, in the Gantt Chart View on the right, will turn Red in color. 

2.1.5 Future Study: https://www.youtube.com/watch?v=_eD2u8bxecs 
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2.2 QGIS (Quantum Geographic Information system) 

2.2.1 Introduction to QGIS 

QGIS is a popular open-source GIS with advanced capabilities 

2.2.2 Objectives 

To create shape files for determining the latitude, longitude, length and area quantities using 

QGIS software 

2.2.3 Initializing QGIS 

1. Double click on QGIS destop file from the installed folder to get the working page 

2. Select open layer plugin in the web form menu bar and then select google Street under google 

maps. 

3. Search for the place of interest. Once the desired location is obtained, again go to web > open 

layer plugin > google maps > google satellite to get the satellite image of the desired location. 

4. Then to switch off the google street, just uncheck the layer or to remove, just right click on 

layer > remove > ok to remove the layer from the layer panel. 
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2.2.4 Creating Shape files for determining latitude, longitude, length & area quantities 

Exercise No 1: To find latitude and longitude of a point 

1. Go to layer in the menu bar > create layer > New shape layer. In the dialogue box select point 

> type the name as ATME > Add to wish list > click ok. 

2. Save the point feature as ATME POINT in a folder > click ok. Point feature will be displayed 

in the layer panel 

3. Highlight the layer > click on toggle editing tool in the menu bar > click on add feature option. 

Once the option is selected cursor shape will change. 

4. Place a point on the screen. Give the id no and name for that point in the dialogue box. 

Click ok. Repeat the same to place as many no of points. 

5. Right click on the layer > open attribute table > select field calculator > select virtual field > 

type the name as latitude for output field name > select decimal no as real from the drop down 

for output field type. Set as many no of precision value. Double click on geometry > double 

click on $x from the drop down > click ok. 

6. Latitude for the point will be displayed on the screen. Repeat the same procedure, instead of 

latitude type longitude as field name and select $y from the drop down to get longitude for the 

points. 
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Exercise no 2: To find length of a line 

1. Go to layer in the menu bar > create layer > New shape layer. In the dialogue box select line > 

type the name as ATME > Add to wish list > click ok. 

2. Save the point feature as ATME LINE in a folder > click ok. Point feature will be displayed in 

the layer panel 

3. Highlight the layer > click on toggle editing tool in the menu bar > click on add feature option. 

Once the option is selected cursor shape will change. 

4. Place a line by clicking 2 points on the screen. Give the id no and name for that line in the 

dialogue box. Click ok. Repeat the same to place as many no of lines. 

5. Right click on the layer > open attribute table > select field calculator > select virtual field > 

type the name as length for output field name > select decimal no as real from the drop down 

for output field type. Set as many no of precision value. Double click on geometry > double 

click on $length from the drop down > click ok. 

6. Length for the line will be displayed on the screen. 
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Exercise no 3: To find area of a polygon 

1. Go to layer in the menu bar > create layer > New shape layer. In the dialogue box select 

polygon > type the name as ATME > Add to wish list > click ok. 

2. Save the point feature as ATME AREA in a folder > click ok. Point feature will be displayed 

in the layer panel 

3. Highlight the layer > click on toggle editing tool in the menu bar > click on add feature option. 

Once the option is selected cursor shape will change. 

4. Place a polygon by clicking 4 points on the screen. Give the id no and name for that polygon 

in the dialogue box. Click ok. Repeat the same to place as many no of polygons. 
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5. Right click on the layer > open attribute table > select field calculator > select virtual field > 

type the name as length for output field name > select decimal no as real from the drop down 

for output field type. Set as many no of precision value. Double click on geometry > double 

click on $area from the drop down > click ok. 

6. Area for the polygon will be displayed on the screen. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
2.2.5 Future Study: https://www.youtube.com/watch?v=oOtdogz2GWQ 
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3. USE OF EXCEL SPREAD SHEETS 

 

 
Future Study: https://www.youtube.com/watch?v=qsQdglny6so 
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Design of Horizontal curve 
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Super elevation 

 
 

 
 

Future Study: https://civilread.com/superelevation/ 

 


